1

Resolved

Installing a .NET Framework Version Required by an Application

description

You may have arrived at this page because an app that you tried to run requires a specific version of the .NET Framework that is not installed on your computer. In this case, you may see an error message similar to the following:

Image

To get the app working, install the .NET Framework by choosing one of the links below. Choose the link that matches the version number specified in the error message. For example, the error message above specifies “.NETFramework,Version=4.0”, so that is the version that you would choose from the links below. If the error message you get specifies a different version of the .NET Framework, choose the link that matches that version number.

v1.1.4322
v2.0.50727
Client
v4.0
v4.0.30319
.NET Framework, Version=v4.0, Profile=Client
.NET Framework, Version=v4.0
.NET Framework, Version=v4.0.1, Profile=Client
.NET Framework, Version=v4.0.1
.NET Framework, Version=v4.0.2, Profile=Client
.NET Framework, Version=v4.0.2
.NET Framework, Version=v4.0.3, Profile=Client
.NET Framework, Version=v4.0.3
.NET Framework, Version=v4.5
.NET Framework, Version=v4.5.1

After installing the correct version of the .NET Framework, run the app again. It should run as expected. If you see the same error message again, you may need to install a different .NET Framework version than the one you installed. It is safe to install multiple versions of the .NET Framework on your computer.

comments